FAQs Feed‎ > ‎

How to implement Polycom 3.3.0+ firmware and configuration files on NDP

posted Dec 13, 2012, 3:46 PM by Mamta Buch   [ updated Dec 13, 2012, 3:47 PM ]

NOTE:
Polycom firmware greater than 3.3.0 uses a new configuration file format and syntax.  
During provisioning Polycom phones will retrieve configuration files from the NDP. If no specific version is specified the phone will attempt to retrieve sip.ld.
Users attempting to provision/upgrade Polycom phones using Polycom firmware (3.3.0 or later) via NDP will encounter errors if the following directions are not followed. (e.g phones display may show a messages about existing pre-3.3.0 config file parameters, files may not properly load; or phones may get stuck in a rebooting cycle)

To support all 3.3+  the Polycom firmware files on the NDP must be correctly named to include UC in the title. This tag will trigger the NDP to convert pre 3.3.0 parameters to post 3.3.0 parameters.  So once the firmware file is on your local computer; rename the file as below:

sip.ld should be renamed as UC.sip.ld

2345-11500-040.sip.ld should be renamed as 2345-11500-040.UC.sip.ld



Procedure

  • In the NDP navigate to System → Files & Firmware


  • Click the “Upload File” button


  • Locate the renamed Polycom configuration file on your local computer. 
  • Click the “Start File Upload” button 

  • Once the new file is uploaded on the NDP reboot the appropriate Polycom phone.
Comments